エンジニアリング

wordpress のcode用syntax hight lightに大分悩まされた・・・・

なんでシンタックスハイライトをいれたら・・・逆に困りごとが出るんだ・・・

最近まで使っていたプラグイン

SyntaxHighlighter Evolved を使っていたんです。
そうしたら・・・・何故か < とか > とか やらが変換されるんですよ・・・・ 「<」が「<」になってしまう感じです。

というか、wordpressもこのプラグインも何故勝手にエスケープシーケンスにしやがるんだ・・・(多分セキュア観点?)

変えた・・・・・

なんかもろもろやり方を考えたのだが・・・・・・・・・素直にプラグインを変えました・・・・

Enlighter – Customizable Syntax Highlighter